Tuesday, December 22, 2009

Our Christmas Cactus Bloomed!

I didn't take any pictures, though, because I was trying not to take too much time blogging during finals. And now all of the blossoms are gone.

However, I really enjoyed the blossoms while we had them. I've had the plant for 3 years, and this was the first time it bloomed. They were gorgeous flowers. I've taken the liberty to lift a few pictures from this blog post because I want you to see how pretty the plant was.

Each blossom was attached to the end of a little "leaf" on the cactus, like this.

It was amazing to see how beautiful these blossoms were! The petals of the flower would turn up while the flower hung down from the cactus leaf. So this blossom is actually upside down, and you can see the petals turning up (down in this picture).

I didn't have this many blossoms. I had about 12 little buds come on at the beginning of November, but because I kept picking up the pot to have a closer look and fiddling with the plant, I caused most of those to fall off before they could bloom! Only about 4 or 5 of them actually bloomed.

I am excited to keep my cactus growing, and maybe I'll post some blossom pictures next year!


Naazju said...

I'm sad that those pictures aren't from your own little cactus, but they sure do look beautiful!

Jolena said...

How pretty! Did you know there is a fertilizer you can get that makes flowers bloom? I just found out a few months ago and used it on my African violet. It bloomed probably 100 times after I used the fertilizer. Crazy! It hadn't bloomed for like 2 years, so I thought I'd share so maybe you can get yours to bloom again.

Tara Hoppie said...

So glad your flowers bloomed this year!